Teamviewer9 cannot start (PID file not readable)

D

dimmuboy

Guest
Hi there,
after some updates my TeamViewer is stop working. I do clean install but still no luck.
If I try to start teamviewer


Init...
Checking setup...
Launching TeamViewer ...

..and I got message about daemon is not working.


Please start the daemon (needs root permissions) before running TeamViewer:
teamviewer --daemon start

After clean install or start system status of service is


● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/usr/lib/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2015-11-18 09:33:56 CET; 6min ago
Process: 17700 ExecStart=/opt/teamviewer9/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 17702 (teamviewerd)
CGroup: /system.slice/teamviewerd.service
└─17702 /opt/teamviewer9/tv_bin/teamviewerd -d

Nov 18 09:33:56 dimmubox systemd[1]: Starting TeamViewer remote control daemon...
Nov 18 09:33:56 dimmubox systemd[1]: Started TeamViewer remote control daemon.

..but if I restart service status is changed to


● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/usr/lib/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2015-11-18 09:42:24 CET; 5s ago
Process: 18116 ExecStart=/opt/teamviewer9/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 18119 (teamviewerd)
CGroup: /system.slice/teamviewerd.service
└─18119 /opt/teamviewer9/tv_bin/teamviewerd -d

Nov 18 09:42:24 dimmubox systemd[1]: teamviewerd.service: Unit entered failed state.
Nov 18 09:42:24 dimmubox systemd[1]: teamviewerd.service: Failed with result 'signal'.
Nov 18 09:42:24 dimmubox systemd[1]: Starting TeamViewer remote control daemon...
Nov 18 09:42:24 dimmubox systemd[1]: teamviewerd.service: PID file /run/teamviewerd.pid not readable (yet?) after start: No such file or directory
Nov 18 09:42:24 dimmubox systemd[1]: Started TeamViewer remote control daemon.

I read this thread https://bbs.archlinux.org/viewtopic.php?id=173022 and try to comment out NetworkManager in service file but problem is still here.
btw restart/stop of service or start of teamviewer takes a long time (2 minutes)
 
   
   
   
Top